Sử dụng phiên bản PHP *bất kỳ* với MAMP Free
mac os
6
PHP
78
mamp
1
White

Vũ Thái Học viết ngày 13/07/2015

Tại sao lại *bất kỳ*

Mình chỉ sử dụng trong list này thôi
Danh sách PHP version hỗ trợ

Cách thực hiện

  • Cài MAMP như bình thường (Bỏ qua nếu cài rồi nha)
  • Download phiên bản PHP bạn cần trong list trên tại đây
  • Copy vào thư mục /Applications/MAMP/bin/php/
  • Để lại 2 phiên bản bạn cần, còn lại xóa hoặc thay tên thư mục khác. Chẳng hạn mình để lại 2 thư mục còn lại move sang thư mục /Applications/MAMP/bin/php/f như hình Cấu trúc thư mục /Applications/MAMP/bin/php
  • Bây giờ thì mở hoặc khởi động lại MAMP và vào phần setting PHP version, lúc này bạn sẽ chỉ thấy 2 version bạn để lại mà thôi Cài đặt PHP version
  • Done! code tiếp thôi nào :)

Update 1

Chú ý khi dùng phiên bản PHP khác cần xem sự phù hợp của PhpMyAdmin. Mình đã dùng adminer như một giải pháp thay thế :)

Bình luận


White
{{ comment.user.name }}
Bỏ hay Hay
{{comment.like_count}}
Male avatar
{{ comment_error }}
Hủy
   

Hiển thị thử

Chỉnh sửa

White

Vũ Thái Học

1 bài viết.
1 người follow
Kipalog
{{userFollowed ? 'Following' : 'Follow'}}
Bài viết liên quan
Male avatar
2 0
Trong bài này mình sẽ hướng dẫn các bạn cài đặt Ruby và Rails trên Mac OS (Ảnh) Cài đặt Homebrew Đầu tiên chúng ta cần phải cài đặt Homebrew. H...
Yuto Yasunaga viết 3 năm trước
2 0
{{like_count}}

kipalog

{{ comment_count }}

bình luận

{{liked ? "Đã kipalog" : "Kipalog"}}


White
{{userFollowed ? 'Following' : 'Follow'}}
1 bài viết.
1 người follow

 Đầu mục bài viết

Vẫn còn nữa! x

Kipalog vẫn còn rất nhiều bài viết hay và chủ đề thú vị chờ bạn khám phá!