Laravelのバージョンをアップデートする手順 (Note)
Laravel
41
日本語
1
PHP
96
Male avatar

Minjsa viết ngày 11/07/2019

① まずは composer.jsonファイルを確認する

バージョンをあげよう
"require": {
    "laravel/framework": "5.6.*",
},
※ phpバージョンは7以上が必要です。
"require-dev": {
     "phpunit/phpunit": "^7.0",
},

② 終わったら ターミナルでcomposer updateを実行する
(5分~10分かかる)
composerはプロジェクトのライブラリやパッケージを管理するから、これをアップデートしといてねー
③ 最後にキャッシュクリアために以下のcmdで実行
composer dumpautoload
php artisan view:clear
php artisan cache:clear
php artisan config:clear

以下のcmdでバージョンを確認してみー
php artisan -V
実行結果: Laravel Framework 5.6.24 が表示すればオッケー
これでLaravelバージョンのアップデートが完了するばい。
同じく 5.5 から 5.6 にアップデートしたい時も以上の手順でいける。

Bình luận


White
{{ comment.user.name }}
Bỏ hay Hay
{{comment.like_count}}
Male avatar
{{ comment_error }}
Hủy
   

Hiển thị thử

Chỉnh sửa

Male avatar

Minjsa

1 bài viết.
1 người follow
Kipalog
{{userFollowed ? 'Following' : 'Follow'}}
Bài viết liên quan
White
4 2
Bash script to fast serve Laravel project Lười gõ dòng lệnh quá nên tạo ra cái script để gõ nhanh :D laravelstart.sh /bin/bash if z "$1" ] ...
Vũ Hoàng Chung viết 4 năm trước
4 2
White
0 0
1 Đặt vấn đề Chẳng hạn bây giờ bạn có 1 chuỗi các action diễn ra lần lượt và phụ thuộc vào nhau tạo accountgửi mail cho user, bạn sẽ viết code như...
Kaopiz Software Co., Ltd. viết 2 năm trước
0 0
White
4 2
Trong đợt vừa rồi, mình có cần tìm một framework NodeJS cho dự án. Sau một vòng tìm hiểu mình đã tìm thấy Adonis, một framework NodeJS hoàn thiện đ...
Kaopiz Software Co., Ltd. viết 2 năm trước
4 2
{{like_count}}

kipalog

{{ comment_count }}

bình luận

{{liked ? "Đã kipalog" : "Kipalog"}}


Male avatar
{{userFollowed ? 'Following' : 'Follow'}}
1 bài viết.
1 người follow

 Đầu mục bài viết

Vẫn còn nữa! x

Kipalog vẫn còn rất nhiều bài viết hay và chủ đề thú vị chờ bạn khám phá!